SMS Delivery Failures to Verizon Customers
Incident Report for Parachute Health
Resolved
We have addressed the root cause of this incident and are seeing delivery rates to Verizon in line with normal rates and other carriers. We have resent SMS signature requests for outstanding orders to clinicians who may not have received them during this incident. Service levels have returned to normal across the Parachute platform, and we are actively monitoring. Please reach out to support@parachutehealth.com if you have any questions.
Posted Jul 01, 2023 - 13:23 EDT
Investigating
We are experiencing a high rate of SMS delivery failure to Verizon customers. We are in the process of investigating the root cause of the issue, as well as alternative mechanisms for sending SMS messages to Verizon customers. If you need to reach clinicians digitally in our platform, we recommend using alternative signature request methods where possible.
Posted Jun 30, 2023 - 18:04 EDT