Platform experiencing degraded performance
Incident Report for Parachute Health
Resolved
This incident has been resolved.
Posted Jan 27, 2022 - 14:55 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2022 - 14:50 EST
Identified
Some customers are experiencing slowness and intermittent error messages across the application. Our developers are aware of the problem and are working on it urgently.
Posted Jan 27, 2022 - 12:57 EST
This incident affected: Platform.